Windows下超大动态磁盘93TB数据恢复

起因:单分区磁盘容量不够,我铤而走险使用多卷组合成动态磁盘。某天看zabbix发现D盘不见了,然后日志报磁盘错误。我骚操作转换了基本磁盘,然后就没有然后了。动态磁盘是由一个物理卷加一个VHDX的iscsi挂载卷组成的。

操作分析:

1,开始我是想转换基本磁盘,把物理卷这边转换成功。但由于数据已经写满了磁盘,无法保存分区操作。虽然也能读取到数据。由于我又开了重复删除,必须得整卷恢复才能完整恢复数据。

2,因为整个分区是93TB,所以我必须购买了100TB的磁盘回来。本来是打算用100TB的服务器磁盘创建VHDX用iscsi挂载,然后扇区拷贝过来转为基本磁盘。发现VHDX最大只能64TB。这个只能放弃。

3,然后想到用多个VHDX挂载组成动态磁盘进行扇区复制。但发现工具Diskgunius不支持这么做。后来发现是没有更新,加上这个Diskgunius注册版失效了。(磁盘这里出了点小插曲,第一次买的服务器R740是8个12TB,发现容量完全不够,害得我厚着脸皮又申请了个Dell硬盘柜16TB*7。但是没那么快到,我只好做两手准备,一是利用现有的磁盘空间组成动态磁盘先进行恢复,看Windows能否识别动态分区对分区的扇区复制。二是等硬盘柜到了,直接进行扇区复制,转为基本磁盘。)

4,方案确定后。我先进行了第一个方案。大约过了一天24小时,复制了一半,硬盘柜就到了。遂停止了复制,因为觉得第二个方案靠谱点。然后就折腾了硬盘柜。发现DELL H840的扩展卡 不能支持超微UEFI启动下进行初始化。等改完设置通过自检进入系统后,我发现刚复制的扇区的分区竟然能看到数据了。我兴奋之余,就没折腾硬盘柜,继续复制了。这里要赞一下Diskgunius,他竟然关机后能保存之前扇区复制的进度,我就不用从头开始复制了。

5,其实折腾到这里已经过了五天了,我跟所有公司的同事说下周一一定能搞定的。到了星期六,所有数据复制完毕。我一大早就发布了消息,数据恢复完成。心里的石头总算落下了。

具体操作写起来太麻烦,看过程吧。这里要感谢Diskgunius技术支持。

用Windows AD域给Apache签发证书

因为在内网搭建一些一些应用网站,一直没空的用的http。但是我这个骚操作,网上竟然没有类似案列。随手写一写,做个备忘。

1,把Windows的证书颁发机构角色安装好,IIS服务管理器当然也是要安装好的。安装好后,到IIS管理器去创建证书申请。如下图

2,创建好申请,下载好证书后,再从上图这里右侧点击完成证书申请,选择刚才下载的证书文件,友好的名称自己随便。

3,完成之后再选择,刚导入的证书。选择它导出,然后提示你设置密码。导出的是个pfx文件。这一步是要得到key文件。

4,最后你就得到了pfx证书文件。然后用下面的命令转换你需要的crt、key文件

 (1)openssl pkcs12 -in  xxx.pfx -nodes -out server.pem

  (2)从.pem文件中导出私钥server.key:
  openssl rsa -in server.pem -out server.key 

  (3)从.pem文件中导出证书server.crt
  openssl x509 -in server.pem -out server.crt

最近是越来越忙

1,其实不是真的很忙,还是有时间,不知怎么的就是不愿意动

2,我觉得自己的生活被工作绑架了.下班后想得都是工作

3,最近和对象有一点是出奇的一致,我们都是快要死的人了.哈哈哈

4,我觉得自己还是有炒股的天赋,觉得还能挽救下自己

5,最近公司的一个服务器的文件全部丢失,经过6天的拯救,我终于给恢复了.好开心

6,对公司现在的情况 我觉得是越来越糟.就像一坨屎.还查不干净的那种.好心累

Mikrotik Ros路由 设置 eoip 断线自动连接 仅限ddns有公网ip

设置全局本地ipv4接口

:global WANInterface “pppoe-out1”

设置tunnel-id

:local tid “141”

设置numbers,就是规则排序,从上往下,0开头

:local num “5”

设置 eoip name

:local eoname “eoip-tunnel-ns”

设置对方ddns地址

:local ddnsdomain “90.life”

########### 内部变量

设置变量 ipv4

:local localIP “”

:local remoteIP “”

:global WANip “”

########### 解析和设置IP变量

获取本地公网IPv4

:set localIP [/ip address get [/ip address find interface=$WANInterface ] address];

:set WANIP [:pick $localIP 0 [:find $localIP “/”]];

获取远程域名IPv4

:set remoteIP [:resolve $ddnsdomain];

/interface eoip
set name=”$eoname” tunnel-id=$tid local-address=$WANIP remote-address=$remoteIP numbers=$num;

:log info (“对方公网IPv4 $remoteIP”)
:log info (“当前公网IPv4 $WANip”)

ps:仅适用两方都有ddns并且都有公网地址.网上搜了一圈没有类似教程.故在此献丑了.然后自己按需求添加任务(Schedule)或者断线检测(netwatch)