Mikrotik Ros路由 设置 eoip 断线自动连接 仅限ddns有公网ip

设置全局本地ipv4接口

:global WANInterface “pppoe-out1”

设置tunnel-id

:local tid “141”

设置numbers,就是规则排序,从上往下,0开头

:local num “5”

设置 eoip name

:local eoname “eoip-tunnel-ns”

设置对方ddns地址

:local ddnsdomain “90.life”

########### 内部变量

设置变量 ipv4

:local localIP “”

:local remoteIP “”

:global WANip “”

########### 解析和设置IP变量

获取本地公网IPv4

:set localIP [/ip address get [/ip address find interface=$WANInterface ] address];

:set WANIP [:pick $localIP 0 [:find $localIP “/”]];

获取远程域名IPv4

:set remoteIP [:resolve $ddnsdomain];

/interface eoip
set name=”$eoname” tunnel-id=$tid local-address=$WANIP remote-address=$remoteIP numbers=$num;

:log info (“对方公网IPv4 $remoteIP”)
:log info (“当前公网IPv4 $WANip”)

ps:仅适用两方都有ddns并且都有公网地址.网上搜了一圈没有类似教程.故在此献丑了.然后自己按需求添加任务(Schedule)或者断线检测(netwatch)

ESXi更改主机名,配置证书遇到的坑

1,为了不想老弹出那个证书的对话框,配置了一个证书,并更改了主机名。然而掉坑开始。

主机名、FQN倒是好改,两行命令就解决了

esxcli system hostname set –host=hostname
esxcli system hostname set –fqdn= fqdn

2,配置证书踩坑了。改了主机名如果不重启,默认生成的证书签名请求是之前的FQN。然而我以为是web界面出问题了,又在来了一次。然后web就挂了,连命令行进去敲命令都是错误提示 IO error: [Errno 111] Connection Refused.。搞得我以为机器挂了。

3,后来终于在一篇帖子找到了方法,就是删除/etc/vmare/ssl下的rui.crt rui.key.用自带证书程序  /sbin/generate-certificates 重新生成

Exchange 2019 收发邮件设置

1,安装好后,设置好发送器。默认就可以发送邮件。

2,如果是内网,接收邮件请打开25端口的映射。

3,如果仅是收发邮件,无需外网web或客户端互联。其他端口可以不打开。

4,默认的发送域fqn,ui界面是无法修改的,会报错。需要手动打开exchange shell命令行修改。格式如下

Set-ReceiveConnector -Identity “Default Frontend Mailbox01” -Banner “220 consoso.com”

5,请使用固定IP地址作为外网出口,强制内网服务器的IP走这个出口IP出去。